activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim Bain <tb...@alumni.duke.edu>
Subject Re: Active MQ - runtimeConfigurationPlugin - Set Message Priority - Not working
Date Sat, 15 Jul 2017 04:08:32 GMT
I finally got some time to dig into the code, and discovered that the
PolicyEntry.update() and PolicyEntry.baseUpdate() methods (
https://git-wip-us.apache.org/repos/asf?p=activemq.git;a=blob;f=activemq-broker/src/main/java/org/apache/activemq/broker/region/policy/PolicyEntry.java;h=5b7ff0e184b9e6b4be6cf61ebcacc0a845bb1a6c;hb=HEAD)
don't attempt to set any of the three properties you're passing in.

I don't have any insight into why they wouldn't; maybe there's some reason
I'm not aware of why those specific attributes can't be updated (in which
case, we should document that on the wiki so users like you don't have to
find this out the hard way), but more likely they were just an oversight.
Can you please submit a bug in JIRA requesting that those attributes be set
when the policy entry is reloaded?

Thanks,
Tim

On Fri, Jul 14, 2017 at 6:48 PM, akpuvvada <akp4tibco@gmail.com> wrote:

> Sorry, Tim. I miss understood your previous question.
> If I restart with the policy configured, the property is getting applied
> and
> it is working as expected. It is only not happening if I try to have it
> updated at runtime.
>
>
>
> --
> View this message in context: http://activemq.2283324.n4.
> nabble.com/Active-MQ-runtimeConfigurationPlugin-Set-Message-Priority-Not-
> working-tp4728264p4728565.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message