activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dan Langford <danlangf...@gmail.com>
Subject [Artemis 2.1.0] struggling to produce AMQP1.0 messages on a cluster (server side load balancing)
Date Tue, 18 Jul 2017 23:00:41 GMT
I could use some help. We set up an Artemis cluster (2.1.0) and at first
glance it was looking great using the command line tools to produce and
consumer messages verified that they were getting distributed through the
cluster just fine. When we switched over to using AMQP1.0 via the
qpid-jms-client library we started getting some problems. We think the
pattern we have observed is as soon as the cluster tries to send an AMQP
message to another node in the cluster an exception is thrown server side.

I built on top of the example `clustered-static-discovery` to
demonstrate/reproduce this behavior.
https://github.com/danlangford/tq-artemis-example when you run `mvn`verify
it first executes the stock `clustered-static-discovery` example
successfully and then it moves into my test using QPID client libs (thus
AMQP) and you can see the exception that the server
throws. [org.apache.activemq.artemis.protocol.amqp.proton.ProtonServerReceiverContext]
null: java.lang.UnsupportedOperationException

Does anybody have any insight into producing messages into a cluster via
AMQP1.0? Maybe i need to tweak my broker configuration? Maybe I am
misunderstanding something?

for the record when not clustered the QPID libs / AMQP1.0 is all working
great against the artemis broker.

Thanks your your time and consideration.

Dan Langford

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message