activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From neelam <neelam.ba...@emc.com>
Subject After upgrading activemq to 5.14.5 to 5.6.0 SSL communication to external server is broken
Date Fri, 21 Jul 2017 10:44:34 GMT
Hi,

I have upgraded activemq recently to 5.14.5 from 5.6.0 version. After the
upgrade I see the SSL communication with external server is not working.
After enabling the ssl logs I see the below error:

 java.net.SocketException: java.security.NoSuchAlgorithmException: Error
constructing implementation (algorithm: Default, provider: SunJSSE, class:
sun.security.ssl.SSLContextImpl$DefaultSSLContext)

In catalina logs I also see that it's not able to load all the certificates
present in cacerts and just stops.

Just for background, I was using activemq-all artifact earlier and for
upgrading to 5.14.5 I have to use activemq-kahadb-store artifact which is
dependent on broker and client. Thus after the upgrade instead of one
activemq jar activemq-all-5.6.0.jar I have below 5 jars in my installation :

activemq-broker-5.14.5.jar           activemq-kahadb-store-5.14.5.jar    
activemq-protobuf-1.1.jar
activemq-client-5.14.5.jar           activemq-openwire-legacy-5.14.5.jar
 
Do I need any other dependency for SSL communication to work?

I have tried replacing all 5.14.5 activemq jars with activemq-all-5.6.0.jar
and SSL communication works fine which gives me the impression that there is
some other dependency for SSL , which I am missing.

Regards
Neelam



--
View this message in context: http://activemq.2283324.n4.nabble.com/After-upgrading-activemq-to-5-14-5-to-5-6-0-SSL-communication-to-external-server-is-broken-tp4728762.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message