activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim Bain <tb...@alumni.duke.edu>
Subject Re: Wildcards in composite destinations not working...
Date Sun, 18 Jun 2017 17:05:14 GMT
I've never seen anything that indicates that wildcards are allowed in
composite destinations, but if it was going to work the way you're trying
it, you would need to modify your expression to put a period before the >
in composite topic's name. Wildcards in ActiveMQ are only allowed to match
a full name within a path, so Advisory> is not a legal name expression.

But I think you'll find that even if you fix that problem, it's still not
going to do what you want. Instead, you could create an embedded Camel
route, since those do support wildcard matches.

Tim

On Jun 13, 2017 7:52 AM, "Raffi" <raffi.onjava@gmail.com> wrote:

We're trying to channel all advisory events generated from a standalone
broker to a queue, but nothing is ever forwarded to the queue. This appears
to only work when the composite topic does NOT use * or >, is this by
design?

   <virtualDestinationInterceptor>
        <virtualDestinations>

            <compositeTopic name="ActiveMQ.Advisory>" forwardOnly="false">
                        <forwardTo>
                                <queue physicalName="admin.events.all" />
                        </forwardTo>
            </compositeTopic>

        </virtualDestinations>
    </virtualDestinationInterceptor>

Is this



--
View this message in context: http://activemq.2283324.n4.
nabble.com/Wildcards-in-composite-destinations-not-working-tp4727353.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message