activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Clebert Suconic <clebert.suco...@gmail.com>
Subject Re: Artemis as MQTT broker fail when load testing 10k publishers QoS1
Date Fri, 23 Jun 2017 20:37:26 GMT
Can you try a snapshot from master?


On Thu, Jun 22, 2017 at 7:54 AM, ublanquet <ublanquet@gatling.io> wrote:
> Hello, I am currently using an artemis server as a mqtt broker for load
> testing, and it seems sending messages with QoS1 make it blow up pretty fast
> (10k connections publishing  1 message/s, usually break right at the end of
> the first 10k batch, my client receive 10k messages or less):
> I get a lot of duplicate ack in the server log, queues freeze "taking too
> long to flush deliveries", then I get "unable to send message" errors
> because "AMQ119027: Could not find reference on consumer ID=15", and when
> killing the frozen process, I get "Timed out waiting for write lock on
> consumer." and a thread dump.
> Do you guys think it's a config problem, or a bug ? (a mosquitto server
> takes way longer to accept the connections, but deal with the messages just
> fine).
>
> Attached are server log, thread dump, broker.xml
> artemis.log
> <http://activemq.2283324.n4.nabble.com/file/n4727737/artemis.log>
> l artemis-thread_dump.log
> <http://activemq.2283324.n4.nabble.com/file/n4727737/artemis-thread_dump.log>
> broker.xml <http://activemq.2283324.n4.nabble.com/file/n4727737/broker.xml>
>
> Typical relevant logs part
>
>
>
>
> --
> View this message in context: http://activemq.2283324.n4.nabble.com/Artemis-as-MQTT-broker-fail-when-load-testing-10k-publishers-QoS1-tp4727737.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.



-- 
Clebert Suconic

Mime
View raw message