activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Justin Bertram <jbert...@apache.org>
Subject Re: Artemis - HA cluster with master and two backups
Date Thu, 01 Jun 2017 13:40:47 GMT
> ...starting from the point when all three servers working normally, master is live, backup1
is in sync with master, backup2 is spare backup.  Now I stop backup1 and expect that backup2
(spare backup) will detect crash of backup and replaces first backup by syncing with master.
But that does not happen.

Multiple backups is not generally recommended and certainly not widely tested so I think you've
hit a use-case which isn't currently supported.

Feel free to open a JIRA for this.  We'd welcome a PR for the implementation as well, but
if you're unable to provide a solution then I think someone will get to it eventually.


Justin

----- Original Message -----
From: "nkhasanov" <nk.khasanov@gmail.com>
To: users@activemq.apache.org
Sent: Thursday, June 1, 2017 7:04:15 AM
Subject: Artemis - HA cluster with master and two backups

Hi,

I'm trying to evaluate the following scenario. I have a cluster of 1 master
and two backups. When I start all three servers one backup connects and
syncs with master, second stays as spare backup and does not sync. That's
more or less ok and at least according to documentation as I understood it.

When I stop master, then first backup becomes live and second (spare) backup
detects crush of the master and connects and syncs with new live broker
(first backup). That's also fine and expected.

What I could not achieve so far is the following scenario. Again starting
from the point when all three servers working normally, master is live,
backup1 is in sync with master, backup2 is spare backup. 
Now I stop backup1 and expect that backup2 (spare backup) will detect crash
of backup and replaces first backup by syncing with master. But that does
not happen. I cannot see any reaction neither in master log, nor in backup2
log - data is not replicating, backup is not announcing.

Is it by design or seems to be a defect? I tried Artemis 1.2.0, 1.5.5 and
2.1.0 - same behaviour.
I use static connectors in cluster connections and as I said master crash
scenario works fine as well as different starting order of backup brokers,
so they see each other. I tested it on local machine.

I'd appreciate in any help here.

Thanks,
Nikolay



--
View this message in context: http://activemq.2283324.n4.nabble.com/Artemis-HA-cluster-with-master-and-two-backups-tp4726866.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message