activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Clebert Suconic <clebert.suco...@gmail.com>
Subject Re: Artemis v2.0 JDK8 dependency
Date Wed, 10 May 2017 17:30:09 GMT
We can probably fix 1.5.x.. I'm not sure about the dependencies.

On Wed, May 10, 2017 at 1:11 PM, abhijith <topcoderabhijith@gmail.com> wrote:
> Another note which is on v1.5.4.  This version also suffers from same
> bytecode compatibility issues.
>
> [INFO] --- maven-enforcer-plugin:1.4.1:enforce (enforce) @
> credit-artemis-client ---
> [INFO] Restricted to JDK 1.7 yet
> org.apache.activemq:artemis-journal:jar:1.5.4:test contains
> org/apache/activemq/artemis/core/io/AbstractSequentialFile$1.class targeted
> to JDK 1.8
> [INFO] Restricted to JDK 1.7 yet
> org.apache.activemq:artemis-core-client:jar:1.5.4:compile contains
> org/apache/activemq/artemis/api/config/ActiveMQDefaultConfiguration.class
> targeted to JDK 1.8
> [INFO] Restricted to JDK 1.7 yet
> org.apache.activemq:artemis-jdbc-store:jar:1.5.4:test contains
> org/apache/activemq/artemis/jdbc/store/drivers/AbstractJDBCDriver$1.class
> targeted to JDK 1.8
> [INFO] Restricted to JDK 1.7 yet
> org.apache.activemq:artemis-commons:jar:1.5.4:compile contains
> org/apache/activemq/artemis/api/core/ActiveMQAddressExistsException.class
> targeted to JDK 1.8
> [INFO] Restricted to JDK 1.7 yet
> org.apache.activemq:artemis-server:jar:1.5.4:test contains
> org/apache/activemq/artemis/api/core/management/MessageCounterInfo.class
> targeted to JDK 1.8
> [INFO] Restricted to JDK 1.7 yet
> org.apache.activemq:artemis-service-extensions:jar:1.5.4:test contains
> org/apache/activemq/artemis/service/extensions/ActiveMQServiceExtensionLogger.class
> targeted to JDK 1.8
> [INFO] Restricted to JDK 1.7 yet
> org.apache.activemq:artemis-jms-server:jar:1.5.4:test contains
> org/apache/activemq/artemis/jms/bridge/ActiveMQJMSBridgeLogger.class
> targeted to JDK 1.8
> [INFO] Restricted to JDK 1.7 yet
> org.apache.activemq:artemis-native:jar:1.5.4:test contains
> org/apache/activemq/artemis/jlibaio/LibaioContext$1.class targeted to JDK
> 1.8
> [INFO] Restricted to JDK 1.7 yet
> org.apache.activemq:artemis-cli:jar:1.5.4:test contains
> org/apache/activemq/artemis/cli/Artemis.class targeted to JDK 1.8
> [INFO] Restricted to JDK 1.7 yet
> org.apache.activemq:artemis-dto:jar:1.5.4:test contains
> org/apache/activemq/artemis/dto/AppDTO.class targeted to JDK 1.8
> [INFO] Restricted to JDK 1.7 yet
> org.apache.activemq:artemis-jms-client:jar:1.5.4:compile contains
> org/apache/activemq/artemis/api/jms/ActiveMQJMSClient.class targeted to JDK
> 1.8
> [INFO] Restricted to JDK 1.7 yet
> org.apache.activemq:artemis-selector:jar:1.5.4:compile contains
> org/apache/activemq/artemis/selector/filter/ArithmeticExpression$1.class
> targeted to JDK 1.8
>
> I think JDK8 dependency should be clarified in documentation.
>
>
>
>
>
> --
> View this message in context: http://activemq.2283324.n4.nabble.com/Artemis-v2-0-JDK8-dependency-tp4725798p4725907.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.



-- 
Clebert Suconic

Mime
View raw message