activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Justin Bertram <jbert...@apache.org>
Subject Re: Artemis v2.0 JDK8 dependency
Date Wed, 10 May 2017 19:04:57 GMT
Actually, using <jms> in broker.xml *is* still supported. You just need to add a reference
to the artemis-jms.xsd in the "schemaLocation" of your broker.xml.

To be clear, queues and topics defined in <jms> won't be prefixed with "jms.queue."
and "jms.topic." respectively.

In general it is recommended that you use the new addressing scheme. As Clebert mentioned,
there is a "migrate1x" command on the CLI that can take your 1.x broker.xml and spit out an
equivalent 2.x broker.xml.


Justin

----- Original Message -----
From: "abhijith" <topcoderabhijith@gmail.com>
To: users@activemq.apache.org
Sent: Wednesday, May 10, 2017 10:16:34 AM
Subject: Re: Artemis v2.0 JDK8 dependency

Thanks for the clarification.  

Since we are talking about upgrade had one more question.

Is defining JMS queues using <jms> tag in broker.xml not valid anymore in
Artemis v2.0?  I looked at JMS examples and it has been moved to new
<address> model.  But I could still see bunch of references of it under
tests/integration-tests.



--
View this message in context: http://activemq.2283324.n4.nabble.com/Artemis-v2-0-JDK8-dependency-tp4725798p4725893.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message