activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From abhijith <topcoderabhij...@gmail.com>
Subject Re: Artemis v2.0 JDK8 dependency
Date Tue, 09 May 2017 02:34:29 GMT
Thanks for the info.  Our broker itself is running on Jdk8, so that is not a
problem.  

Its the client I am concerned about.  We have a mixture of Jdk7 and jdk8
clients(publishers and consumers).  So, we would like to give them an option
to use either and upgrade to jdk8 at their convenient time.

We do use JAAS module to hook up our custom authentication mechanism.  We
are also using netty connectors both for cluster and also from client to
server.  We are using JMS currently and have no plans to switch to AMQP.

With these constraints, do you guys recommend to upgrade to 2.0 or it is
better to stay in 1.x?



--
View this message in context: http://activemq.2283324.n4.nabble.com/Artemis-v2-0-JDK8-dependency-tp4725798p4725816.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message