activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim Bain <>
Subject Re: | WARN | Transport Connection to: tcp://xx.xx.xx.xx:xxxxx failed
Date Tue, 18 Apr 2017 03:38:55 GMT
TCP connections are always bi-directional; even if you don't pass
application-layer content in one direction, you still have to send acks for
the messages containing content coming in the other direction.

There's another email thread (
that started back in early March and was revived just a few days ago by
another user, where the original poster saw the same behavior you did and
it appeared to be due to the load balancer's activity tests as it tried to
determine if the broker was alive.  The first place I'd suggest you look is
whether that would fully explain what you're seeing.

Also, please search the mailing list archives before posting; often, like
in this case from what it sounds like, there's someone who's already had
and solved exactly the problem you're experiencing.


On Mon, Apr 17, 2017 at 6:15 PM, Hidekazu <> wrote:

> Hi everyone.
> I want your help to understand what have happened on my ActiveMQ.
> I use AcitveMQ ver 5.14.3.
> I noticed that I had a lot of WARN logs on the ActiveMQ as follows.
> ------------------------
> 2017-04-11 00:00:07,675 | WARN  | Transport Connection to:
> tcp:// failed: |
> | ActiveMQ
> Transport: tcp:///
> --------------------------
> This is our architecture.
> Internet----FW----(8883)LoadBalancer----(8883)TCP
> repeater----(58883)ActiveMQ
> * There is no firewall between TCP repeater and ActiveMQ.
> * TCP repeater changes port number from 8883 to 58883 and publish data to
> ActiveMQ.
> * (Actually, TCP repeater just repeats TCP flow and don't understand MQTT
> at
> all.)
> * ActiveMQ ip address isn't written in the log.
> * TCP repeater ip address is
> I thought the direction of TCP connection was always one way, from internet
> to ActiveMQ(left to right)
> However, it seems that the connections from ActiveMQ to TCP repeater failed
> from the log I wrote above.
> Is there any syn packet from ActiveMQ?
> We'd finished an integration test and didn't have any issue about our
> service even though we have these warnings.
> However, I'm afraid the warning cause something bad to our system.
> Can anyone tell me what the warning is?
> Thanks.
> hidekazu
> --
> View this message in context: http://activemq.2283324.n4.
> xxxxx-failed-tp4725008.html
> Sent from the ActiveMQ - User mailing list archive at

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message