activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim Bain <tb...@alumni.duke.edu>
Subject Re: activemq ramdomly re-deliver messages to consumer
Date Tue, 14 Mar 2017 01:52:12 GMT
That version of ActiveMQ is five and a half years old. It's possible that
the behavior you're seeing is still a bug in the current version, but it's
quite possible that it's been fixed in one of the nine minor releases (and
more incidental releases) since then. Upgrading to a more recent version is
probably a good idea.

In the meantime, you could go through the JIRA entries for the releases
since 5.5.1 to see if any of them match the behavior you're seeing.

Tim


On Mar 13, 2017 7:18 PM, "bwen" <wenbin6286@gmail.com> wrote:

All
I have a strange issue with activemq. I see sometimes it re-deliver the same
messages to consumers.
Sometimes this happens the same day, some times it happens after couple
days.
Here are my setups:
AMQ version 5.5.1 running active/backup mode
using JDBC as persistent I can see messages are stored in activemq_msgs
table.
the url on consumer side is

<value>failover:(${jms.broker1.uri},${jms.broker2.
uri})?randomize=false&amp;jms.prefetchPolicy.queuePrefetch=
1&amp;maxReconnectAttempts=-1</value>

Is there anyone else see the similar issues and know how to fix it?

thanks in advance.





--
View this message in context: http://activemq.2283324.n4.
nabble.com/activemq-ramdomly-re-deliver-messages-to-consumer-tp4723731.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message