activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Harrison Tarr <harrison.t...@connexta.com>
Subject Re: Ping address wasn't reachable
Date Thu, 02 Mar 2017 20:01:48 GMT
I may very well be misunderstanding. 
But I think my most pressing issue is that since the NetworkHealthCheck is failing, my servers
are not coming up at all, even when they’re supposed to. I have tried to start my backup
(without the ‘master’ node running) and the backup does not start Artemis, because it
can’t ping any address.

I’m going to investigate further, setting the log level to trace, like Justin recommended.
 

-Harrison

On 3/2/17, 12:52 PM, "Clebert Suconic" <clebert.suconic@gmail.com> wrote:

    Maybe you're misunderstanding how NetworkHealthCheck works?
    
    
    This is required only to make sure your server will not run in case
    you pull out the network cable.
    
    So, if you set the ping Address towards apache.org, your server would
    shutdown itself whenever your internet connection drops or the
    apache.org is shutdown. it will be pure ping.
    
    
    
    that's just to avoid a backup from activating because the network
    connection dropped.
    
    On Thu, Mar 2, 2017 at 2:41 PM, Harrison Tarr
    <harrison.tarr@connexta.com> wrote:
    > Please find my broker.xml and backup broker.xml attached. They work when I comment
out the “<network-check-list>” but don’t fail-over if I kill the master.
    >
    > Regards,
    >
    > Harrison Tarr
    >
    > On 3/2/17, 12:33 PM, "Clebert Suconic" <clebert.suconic@gmail.com> wrote:
    >
    >     It is possible to be a bug on windows...
    >
    >
    >     Can you share your settings? I will take a look.
    >
    >     On Thu, Mar 2, 2017 at 12:29 PM, Harrison Tarr
    >     <harrison.tarr@connexta.com> wrote:
    >     > Hello,
    >     >
    >     > I’m trying to configure HA using Artemis on a Windows machine. My coworker
was able to get the “network-check-list” to work with a simple list of IPs. We are using
the same broker.xml. When I use it, I get an error in the log that says
    >     > “08:56:49,975 | WARN  | ca9-d991d17b6f42 | q.artemis.core.server.NetworkHealthCheck
 206 | ogging.jboss-logging | Ping Address /192.30.252.153 wasn't reacheable”
    >     >
    >     > The leading “/” in the IP seems suspicious to me. I have tried using
the default ping command, as well as editing it to be just “ping.” I have also tried with
a list or a single IP. I have also verified that the addresses are reachable from the machine,
just the ping fails. Could there be some parsing error on Windows that is prepending a “/”?
    >     >
    >     > Regards,
    >     >
    >     > Harrison Tarr
    >
    >
    >
    >     --
    >     Clebert Suconic
    >
    >
    
    
    
    -- 
    Clebert Suconic
    

Mime
View raw message