activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gerrit Tamboer <Gerrit.Tamb...@crv4all.com>
Subject Problems setting up replicated ha-policy.
Date Thu, 26 Jan 2017 12:23:32 GMT
Hi community,

We are attempting to setup a 3 node Artemis (1.3.0) cluster with an active-passive failover
situation. We see that the master node is actively accepting connections:

09:52:30,167 INFO  [org.apache.activemq.artemis.core.server] AMQ221000: live Message Broker
is starting with configuration Broker Configuration (clustered=true,journalDirectory=./data/journal,bindingsDirectory=./data/bindings,largeMessagesDirectory=./data/large-messages,pagingDirectory=/opt/jamq_paging_data/data)
09:52:33,176 INFO  [org.apache.activemq.artemis.core.server] AMQ221020: Started Acceptor at
0.0.0.0:61616 for protocols [CORE,MQTT,AMQP,HORNETQ,STOMP,OPENWIRE]

The slaves are able to connect to the master and are reporting that they are in standby mode:


08:16:57,426 INFO  [org.apache.activemq.artemis.core.server] AMQ221000: backup Message Broker
is starting with configuration Broker Configuration (clustered=true,journalDirectory=./data/journal,bindingsDirectory=./data/bindings,largeMessagesDirectory=./data/large-messages,pagingDirectory=/opt/jamq_paging_data/data)

08:18:38,529 INFO  [org.apache.activemq.artemis.core.server] AMQ221109: Apache ActiveMQ Artemis
Backup Server version 1.3.0 [null] started, waiting live to fail before it gets active

However, when I kill the master node now, it reports that the master is gone , but does not
become active itself:


08:20:14,987 WARN  [org.apache.activemq.artemis.core.client] AMQ212037: Connection failure
has been detected: AMQ119015: The connection was disconnected because of server shutdown [code=DISCONNECTED]


When I do a kill -9 on the PID of the master java process, it does not even report that the
master has gone away.

I also tested this in Artemis 1.5.1, with the same results. Also removing one of the slaves
(to have a simple master-slave setup), also does not work.

My expectation is that if the master dies, one of the slaves becomes active.

Attached you will find the broker.xml of all 3 nodes.

Thanks in advance for the help!

Kind regards,
Gerrit Tamboer


This message is subject to the following E-mail Disclaimer. (http://www.crv4all.com/disclaimer-email/)
CRV Holding B.V. seats according to the articles of association in Arnhem, Dutch trade number
09125050.
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message