activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Timothy Bish <tabish...@gmail.com>
Subject Re: How to enable SSL over ActiveMQ using C client
Date Fri, 06 Jan 2017 15:20:54 GMT
I'd recommend asking the Paho folks for instructions on using the Paho 
client and debugging it

You can do some SSL level debug on the Java side of things, see these 
docs for some tips on turning on debug.
http://activemq.apache.org/ssl-transport-reference.html
http://activemq.apache.org/how-do-i-use-ssl.html

On 01/06/2017 04:27 AM, arjun13 wrote:
> I am trying to connect a C client with activeMQ using ssl.For this I created
> certificates using the following link
> https://github.com/rethab/php-stomp-cert-example/blob/master/README.md
> <http://https://github.com/rethab/php-stomp-cert-example/blob/master/README.md>
> Also I confiugured activeMQ with transport connectors as:
> <transportConnector name="ssl"
> uri="mqtt+ssl://0.0.0.0:61613?maximumConnections=1000&wireFormat.maxFrameSize=104857600"/>
>
> The portion of C client uisng SSL is as follows:
> MQTTClient_SSLOptions ssl_opts = MQTTClient_SSLOptions_initializer;
> ssl_opts.enableServerCertAuth = 0;
> conn_opts.ssl = &ssl_opts;
> conn_opts.ssl->keyStore = "/home/user/certs/client-chain.pem";
> conn_opts.ssl->privateKeyPassword = "password";
> conn_opts.ssl->enabledCipherSuites = "DEFAULT";
> MQTTClient_setCallbacks(client, NULL, connlost, msgarrvd, delivered);
> if ((rc = MQTTClient_connect(client, &conn_opts)) != MQTTCLIENT_SUCCESS)
> { printf("%d",rc); }
> But when I connect a C client to activeMQ I get connect failed return code
> -1 error...Kindly help me to fix this issue
>
>
>
> --
> View this message in context: http://activemq.2283324.n4.nabble.com/How-to-enable-SSL-over-ActiveMQ-using-C-client-tp4720869.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>


-- 
Tim Bish
twitter: @tabish121
blog: http://timbish.blogspot.com/


Mime
View raw message