activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Adam Whitney <adam.whit...@sony.com>
Subject Re: Network Connector too slow when receive high rate persistent message
Date Tue, 31 Jan 2017 22:33:58 GMT
Tim,

We just ran another test with all 3 brokers, 2 producer hosts, and 4
consumer hosts ... and made sure that every broker had at least one consumer
host directly connected ... and we saw the queues on broker1 build up
immediately - event during the "ramp up" portion of the test. We're going to
try the same test again - but with conduitSubscriptions="true" and
decreasNetworkConsumerPriority="true" (both are currently false).

What should I look for in the logs to see if Flow Control is kicking in? I
don't think it is because the producers keep on keeping on ... it's the
queues on the brokers that are filling up - but nowhere near to the limit
(we allow 100gb for persistent messages). Producers send persistent messages
inside of transactions ... and consumers also use transactions. And we have
useAsyncSend=true.

System usage is configured as follows:

            <systemUsage>
                <memoryUsage>
                    <memoryUsage percentOfJvmHeap="70" />
                </memoryUsage>
                <storeUsage>
                    <storeUsage limit="100 gb"/>
                </storeUsage>
                <tempUsage>
                    <tempUsage limit="50 gb"/>
                </tempUsage>
            </systemUsage>

ping statistics from broker1 to broker2:

16 packets transmitted, 16 received, 0% packet loss, time 15413ms
rtt min/avg/max/mdev = 0.119/0.175/0.232/0.026 ms

from broker1 to broker3:

16 packets transmitted, 16 received, 0% packet loss, time 15260ms
rtt min/avg/max/mdev = 0.136/0.194/0.271/0.046 ms

from broker2 to broker3:

15 packets transmitted, 15 received, 0% packet loss, time 14507ms
rtt min/avg/max/mdev = 0.174/0.213/0.261/0.029 ms

from broker1 to producer1:

15 packets transmitted, 15 received, 0% packet loss, time 14381ms
rtt min/avg/max/mdev = 0.727/0.819/0.907/0.052 ms

from broker1 to producer2:

15 packets transmitted, 15 received, 0% packet loss, time 14403ms
rtt min/avg/max/mdev = 0.829/0.914/0.987/0.048 ms

from broker1 to consumer1:

15 packets transmitted, 15 received, 0% packet loss, time 14354ms
rtt min/avg/max/mdev = 0.758/0.882/0.963/0.051 ms

from broker1 to consumer2:

15 packets transmitted, 15 received, 0% packet loss, time 14802ms
rtt min/avg/max/mdev = 0.807/0.861/0.916/0.042 ms




--
View this message in context: http://activemq.2283324.n4.nabble.com/Network-Connector-too-slow-when-receive-high-rate-persistent-message-tp4721293p4721448.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message