activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim Bain <tb...@alumni.duke.edu>
Subject Re: Network of Brokers - Connected but messages are not received on second broker
Date Wed, 14 Dec 2016 18:25:25 GMT
Messages exist one one and only one active broker at a time.  If that
happens to be the one you shut down, that message doesn't exist until you
start the broker again.

Your question about why you aren't seeing the message on both brokers at
once sounds like you're still expecting clustering behavior, which does not
exist in ActiveMQ 5.x.

Do you even have two consumers?  Your second message only described a
producer and a consumer...

Tim

On Dec 13, 2016 2:21 PM, "rockies" <lakshmi.chaparala@bd.com> wrote:

> Thank you Tim !, I do see that both brokers work as independent entities.
> But
> I can't tell which client on either broker processed these messages. When
> one broker, say broker 1 comes down or is stopped for upgrades, are the
> messages available on broker 2 also?  Right now when a producer sends
> messages to broker 1, I do not see these messages on broker 2. ----------
> Thanks
>
>
>
>
> --
> View this message in context: http://activemq.2283324.n4.
> nabble.com/Network-of-Brokers-Connected-but-messages-are-
> not-received-on-second-broker-tp4720116p4720295.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message