activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim Bain <tb...@alumni.duke.edu>
Subject Re: Network of brokers: consumers not synchronized
Date Mon, 14 Nov 2016 16:57:52 GMT
Just to be clear: you get "Successfully
connected to ssl://..." each time the connection fails, and never when it
succeeds.  Right?

Can you please provide the filename and line number from that log line?

Tim

On Nov 14, 2016 5:33 AM, "jochenw" <jochen.walz.mail@googlemail.com> wrote:

> Hi,
>
> in the meantime, I have digged bit deeper into that. I can see from the
> logs, that when the mobile radio network connectivity breaks, after 30
> seconds both brokers close the connection and the network broker bridge is
> stopped. Then the network connector tries to reconnect. Most of the time,
> after the mobile radio network is back again, the "mobile broker"
> reconnects
> successfully to the backoffice broker. Both broker logs show an entry, and
> in the Web console of the backoffice broker, I can see the ssl connection.
>
> In some cases, it happens that in the mobile broker log, a "Successfully
> connected to ssl://..." appears. To this broker thinks that it has a
> successful connection. However, no entry appears in the backoffice broker
> log, and the connection can also not be seen in the Web console of this
> broker. Producers/consumers are also not synchronized. Unfortunately, it
> looks like the mobile broker never detects that the broker network is not
> working and doesn't try a reconnection.
>
> I'm pretty sure that I have not observed this while still using 5.11.1 for
> the onboard broker. With 5.13.3 and 5.14.1, the problem appears. Don't know
> about other versions.
>
> Best Regards,
> Jochen
>
>
>
>
> --
> View this message in context: http://activemq.2283324.n4.
> nabble.com/Network-of-brokers-consumers-not-synchronized-
> tp4718852p4719193.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message