activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jochenw <jochen.walz.m...@googlemail.com>
Subject Re: Network of brokers: consumers not synchronized
Date Mon, 21 Nov 2016 16:03:31 GMT
Hi Tim,

how can I see the outbound connection on the mobile broker? I only have the
activemq commands in the karaf shell, and neither activemq:bstat nore
activemq:dstat show the connections. On the backoffice broker, I'm not sure,
but I think that no connection was shown (I will have to wait until the
problem occurs - currently not reproducible on a test setup by simply
bringing up and down the network IF repeatedly). I also assume that it is
the right IP address, since when restarting Karaf (and with it the mobile
broker), connection can be made successfully.

It is expected that without network connectivity, the hostname of the
backoffice broker cannot be resolved, since no DNS is then available to the
mobile system. Most times, after the network connection is back,
reconnection of the brokers works correctly.

By the way: sometimes I also get an InstanceAlreadyExistsException on the
mobile broker for one of the queues. But this looks like another error - in
this case the consumers are there, so the basic network connection exists,
but there is some problem with synchronization of the queues.

Regards,
Jochen



--
View this message in context: http://activemq.2283324.n4.nabble.com/Network-of-brokers-consumers-not-synchronized-tp4718852p4719329.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message