activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim Bain <tb...@alumni.duke.edu>
Subject Re: Consumer is not getting all messages from ActiveMQ
Date Wed, 07 Sep 2016 13:59:36 GMT
Ravi Rapolu recently posted a very similar question; it's possible that
there's a bug.  It's also possible that you're doing something that causes
this in your code; the most obvious possibility is if you're using
CLIENT_ACKNOWLEDGE mode (the default) and your consumer code has a path
where it can exit early (possibly via a return, possibly via an exception)
in some cases.

One way to test whether you're finishing consuming every message is to log
a unique value (a UUID, or even a random number) as the first thing you do
in your consumer code, and then log that you finished the same unique value
as the last line of the consumer code.  Then search the log from the time
period where you observe the problem and see if you have unique values you
started but didn't finish.

Tim

On Sep 2, 2016 9:33 AM, "sushil.chaudhary@capitalone.co" <
sushil.chaudhary@capitalone.com> wrote:

Hi,We are using Active MQ for queue purpose. We have just 1 consumer.  There
are some case, it does not get all messages from ActiveMQ.  If producer
produces messages in Queue in the same rate , consumer consumers --> in that
caes, Consumer gets all messages. But if producer produces messages too fast
in the Queue, consumer does not get all messages and many of the messages
are getting DQueue without going to consumer. What could be wrong here?



--
View this message in context: http://activemq.2283324.n4.
nabble.com/Consumer-is-not-getting-all-messages-from-ActiveMQ-tp4716114.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message