activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christopher Shannon <christopher.l.shan...@gmail.com>
Subject Re: Client - Server version mismatch
Date Tue, 27 Sep 2016 13:49:31 GMT
Running different versions should be ok because OpenWire (the protocol
used) goes through a negotiation process.  The client/sever will negotiate
the highest common protocol version it can so you can use an old client to
talk to a newer server.  That being said there might be some bug fixes in
the newer version so I'd still recommend updating to the latest if you can.

On Tue, Sep 27, 2016 at 9:42 AM, Geoff Mina <gmina@connectfirst.com> wrote:

> How important is it to have the exact same client and server jar versions.
>
> We are running 5.14.0 server but our clients have 5.13.2 jars.
>
> Everything seems ok - but we have had a few weird issues in our network of
> brokers.
>
> Thanks for any insight.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message