activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim Bain <tb...@alumni.duke.edu>
Subject Re: What is the proper way to configure multiple brokers on the same machine in regard to jmx
Date Thu, 18 Aug 2016 12:59:01 GMT
Here's the current version of that file in GitHub:
https://github.com/apache/activemq/blob/master/assembly/src/release/bin/env

I see different lines than you do, even though you're using 5.14.0 which
was just released.  Is there any chance you're not actually using 5.14.0?

Tim

On Aug 18, 2016 2:12 AM, "mlange" <mlange@anwb.nl> wrote:

>
> Tim,
>
> Your comment got me thinking why port 1099 was getting used rather than
> 11099 (and 12099); so I checked my java process and it's parameters: (ps
> -ef
> | grep java); I noticed the parameter telling the port was not in it.
> There's a stupid typo in the "env" files:
> ACTIVEMQ_SUNJMX_START="$ACTIEVMQ_SUNJMX_START
> -Dcom.sun.management.jmx.authenticate=false"
>
> So, fixed that; And now the broker won't start:
>
> Error: Password file not found:
> /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.111.x86_64/jre/
> lib/management/jmxremote.password
>
> This one is a bit strange; I think I said to make an "unsafe,
> unauthenticate
> mbean server"; but at least that problem is out of the way now. Now to get
> both brokers connecting to the same MBean Server (or start one, if none is
> available)... to be continued.
>
>
>
> --
> View this message in context: http://activemq.2283324.n4.
> nabble.com/What-is-the-proper-way-to-configure-multiple-
> brokers-on-the-same-machine-in-regard-to-jmx-tp4715589p4715625.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message