activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From lichtin <lich...@yahoo.com>
Subject Re: Unresolved constraint in bundle activemq-karaf when trying to upgrade to AMQ 5.13.2
Date Wed, 31 Aug 2016 17:28:08 GMT
Understood.
I am suggesting an improvement
https://issues.apache.org/jira/browse/AMQ-6407
as it should still be possible to use ActiveMQ with Karaf 3.x.


christopher.l.shannon wrote
> 5.13.0 was updated to Karaf 4 because of pax web and the upgrade to Jetty
> 9.2.x.
> 
> On Fri, Apr 1, 2016 at 11:48 AM, Martin Lichtin &lt;

> lichtin@.com

> &gt;
> wrote:
> 
>> I see
>>
>> org.osgi.framework.BundleException: Unresolved constraint in bundle
>> activemq-karaf [124]: Unable to resolve 124.0: missing requirement
>> [124.0]
>> osgi.wiring.package;
>> (&(osgi.wiring.package=org.apache.felix.gogo.commands)(version>=0.16.0)(!(version>=1.0.0)))
>>
>> when trying to upgrade ActiveMQ from 5.12.2 to 5.13.2, running in Karaf
>> 3.0.3.
>>
>> Does the latest ActiveMQ require certain minimal Karaf versions?
>>
>>





--
View this message in context: http://activemq.2283324.n4.nabble.com/Unresolved-constraint-in-bundle-activemq-karaf-when-trying-to-upgrade-to-AMQ-5-13-2-tp4710202p4716028.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message