activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From timguy <rasenlatsc...@gmail.com>
Subject One Pending Message but Queue is empty - ActiveMQ 5.12.0
Date Tue, 23 Aug 2016 09:34:26 GMT
I have an issue that pending messages are shown but I can not browser them.

<http://activemq.2283324.n4.nabble.com/file/n4715720/bVHJG.jpg> 
Active MQ shows pending messages for the queue but when I click it it's
empty. Queue with pending message empty queue
<http://activemq.2283324.n4.nabble.com/file/n4715720/7leGf.jpg> 


- Further clients:
    - with hawtio - same behaviour
    - my java consumer
        - does not consume anything
        - after restart, continued to consume

We persist our messages not in default kaha db but in Oracle DB. I could see
the pending messages in database in table ACTIVEMQ_MSGS.

After restart of activeMQ all clients worked as expected. In the
administration console I could see the messages and the java consumer
consumed the messages.

It seems there was once this issue and was solved with an update to ActiveMQ
5.7.0:
http://stackoverflow.com/questions/13470017/activemq-one-pending-message-but-queue-is-empty

I checked the activeMQ logs but I didn't found errors or warnings. Producer
for the messages was also not changed.

Any idea why I experience these issues?




--
View this message in context: http://activemq.2283324.n4.nabble.com/One-Pending-Message-but-Queue-is-empty-ActiveMQ-5-12-0-tp4715720.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message