activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From sekaijin <jean-yves.terr...@sap.aphp.fr>
Subject Re: LevelDB ActiveMQ are there restrictions ?
Date Tue, 02 Aug 2016 12:52:41 GMT
I answer me

It seems that there is actually a bug in the implementation of LevelDB,
more precisely in snappy. this library is used by LevelDB for low-level
operations such as buffer handling, and compression.

Hazelcast the project referenced a similar problem and has introduced an
indicator to use or disable: unsafe.mode.
https://github.com/hazelcast/hazelcast/issues/5518
https://github.com/hazelcast/hazelcast/blob/master/hazelcast/src/main/java/com/hazelcast/nio/UnsafeHelper.java#L96

the snappy project itself has opened a bug on it.
https://github.com/dain/snappy/issues/24

I think we should put a warning in the LevelDB-store page, indicating that
LevelDB can not be used on HP-UX
and perhaps open an issue to keep track of we will change snappy version of
once the bug will be fixed.


A+JYT





--
View this message in context: http://activemq.2283324.n4.nabble.com/LevelDB-ActiveMQ-are-there-restrictions-tp4714969p4714974.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message