activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christopher Shannon <christopher.l.shan...@gmail.com>
Subject Re: jars needed for a jms client application
Date Fri, 17 Jun 2016 16:28:40 GMT
The link you have is from version 5.8 and the dependencies have changed
since then.  Your best bet is to use a tool like Maven or Gradle and to
declare a dependency on activemq-client to build your application so that
it will pull in all of the correct jars needed transitively.  The
dependencies can potentially change in each version (updated versions, etc)
so using tools that automatically manage the dependencies is going to make
things much easier.

I don't know that anyone has an exact list of the dependencies anymore but
it could be determined by running "mvn dependency:tree" on the source which
will list them all.

On Fri, Jun 17, 2016 at 9:43 AM, danny <danny@hazelcast.com> wrote:

>
> Hi,
>
> Which set of jar are needed for a java JMS client application,  to connect
> to my ActiveMQ server
>
> I have activemq-client-5.13.3.jar, on my class path.  but Its not enough,
> i
> get class not found exceptions.
>
>
> up till now I have made do using activemq-all-5.13.3.jar,
>
> however now the size of the jar is causing problems,
> and the fixed logging,  included in the activemq-all-5.13.3.jar has bee
> come
> an issue.
>
>
> I looked at this
> http://activemq.apache.org/maven/5.8.0/activemq-client/dependencies.html
> but it was not enough
>
>
>
> Thanks.
>
>
>
>
>
> --
> View this message in context:
> http://activemq.2283324.n4.nabble.com/jars-needed-for-a-jms-client-application-tp4713101.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message