activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim Bain <tb...@alumni.duke.edu>
Subject Re: Broker network disconnecting every minute
Date Tue, 17 May 2016 03:38:43 GMT
Do you get the same behavior with the tcp transport instead of the ssl
transport?  Also, are you sure the underlying network is completely stable?
On May 16, 2016 2:55 PM, "kgoerlitz" <kevin_goerlitz@bmc.com> wrote:

> What are the best options to use on the transportConnector and
> networkConnectors for a broker network?
>
> I have a hub-spoke broker network using duplex connections from the spokes
> to the hub.  The network connections are being established, but are
> disconnecting and reconnecting every minute.
>
> On the hub broker, I have a transportConnector specified as follows:
>
>
> On the spoke brokers, I have a networkConnector specified as as follows:
>
>
> The spoke broker only receives messages when there is work to be done at
> that broker.  As there is relatively little message activity, I attempted
> to
> turn off the inactivity monitoring, but that does not appear to be working
> as expected.
>
> The messages I get on the spoke broker every minute are:
>
>  INFO | Spoke-Broker bridge to Hub-Broker stopped
>  INFO | Network connection between vm://Spoke-Broker#144 and
> ssl://hub.broker.com/1.234.56.78:61600 (Hub-Broker) has been established.
>  WARN | Network connection between vm://Spoke-Broker#144 and
> ssl://hub.broker.com/1.234.56.78:61600 shutdown due to a remote error:
> java.io.EOFException
>  INFO | Establishing network connection from vm://Spoke-Broker?async=false
> to ssl://hub.broker.com:61600?wireFormat.maxInactivityDuration=0
>
> And on the hub broker, I get the following messages:
>
> WARN | Network connection between vm://Hub-Broker#32712 and
> ssl://9.234.56.78:35003 shutdown due to a remote error:
> java.io.EOFException
> INFO | Connector vm://Hub-Broker stopped
> INFO | Hub-Broker bridge to Spoke-Broker stopped
> INFO | Connector vm://Hub-Broker started
> INFO | Started responder end of duplex bridge
> brokerBridge@ID:2602a9771e91-44698-1463406107596-0:1
> INFO | Network connection between vm://Hub-Broker#32724 and
> ssl://9.234.56.78:35026 (Spoke-Broker) has been established.
>
> Any recommendation on what options to use to keep the connections active
> and
> not reconnecto every minute?
>
>
>
>
> --
> View this message in context:
> http://activemq.2283324.n4.nabble.com/Broker-network-disconnecting-every-minute-tp4712018.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message