activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "James A. Robinson" <jim.robin...@gmail.com>
Subject Re: stomp EOF Exceptions
Date Thu, 21 Apr 2016 16:59:17 GMT
And this discussion may imply that perhaps the issue is with the client is
not being torn down properly from ActiveMQ's pov, but my webconsole always
shows zero producers and zero consumers once the test plugin has completed
its cycle.

https://github.com/apache/activemq-artemis/pull/208#issuecomment-157861049


On Thu, Apr 21, 2016 at 9:18 AM James A. Robinson <jim.robinson@gmail.com>
wrote:

>
> Interesting:
>
> https://github.com/chirino/stomp-benchmark/issues/11
>
>
> On Wed, Apr 20, 2016 at 10:54 AM James A. Robinson <jim.robinson@gmail.com>
> wrote:
>
>> I can't immediately tell if this is a problem with the stomp client or
>> with activemq, but I suspect the latter given what I was seeing.  A
>> monitor I put together to test that messages could be passed on the
>> transports configured for the broker started failing this morning, throwing
>> EOF Exceptions when exercising the stomp+nio transport.
>>
>> The specific exception beeing thrown was  "java.io.EOFException: Peer
>> disconnected".  Using some debugging I could see that openwire and amqp
>> were working fine, but the stomp+nio transport regularly failed.
>>
>> Now, the monitor *had* been working for maybe 12 hours before it started
>> failing.  The setup/teardown of the connections for the monitor are
>> complete, the jvm is being spun up and shut down to run the test, so this
>> isn't a case of a stale connection.
>>
>> What I saw appear in the logs of the broker were:
>>
>> 2016-04-20 08:06:05,481 [IO Worker 10761] WARN  Transport
>>       - Transport Connection to: tcp://10.220.32.43:50705 failed:
>> java.io.IOException: For input string: "1-1"
>>
>> The reason I am suspecting activemq as being at fault, is that I tried
>> deleting the queues it was testing on and re-running the test, and it
>> worked fine.  Right now the monitor is configured to use org.fusesource.stomp.jms.StompJmsConnectionFactory
>> for stomp via JMS.
>>
>> Has anyone seen a similar issue with stomp over activemq?
>>
>> starting test of 10.220.32.43 to 10.220.32.43 using openwire
>> starting to recieve message: 1461172931372
>> got to here: 1461172931377
>> finished test of 10.220.32.43 to 10.220.32.43 using openwire:
>> org.highwire.activemq.NRPEStatus@1a8ee08
>> starting test of 10.220.32.43 to 10.220.32.43 using amqp
>> starting to recieve message: 1461172932341
>> got to here: 1461172932355
>> finished test of 10.220.32.43 to 10.220.32.43 using amqp:
>> org.highwire.activemq.NRPEStatus@7ac83a47
>> starting test of 10.220.32.43 to 10.220.32.43 using stomp+nio
>> starting to recieve message: 1461172932561
>> got to here: 1461172932596
>> finished test of 10.220.32.43 to 10.220.32.43 using stomp+nio:
>> org.highwire.activemq.NRPEStatus@2df36185
>> starting test of 10.220.32.43 to 10.220.32.40 using openwire
>> starting to recieve message: 1461172932630
>> got to here: 1461172932632
>> finished test of 10.220.32.43 to 10.220.32.40 using openwire:
>> org.highwire.activemq.NRPEStatus@21a195b4
>> starting test of 10.220.32.43 to 10.220.32.40 using amqp
>> starting to recieve message: 1461172932783
>> got to here: 1461172932788
>> finished test of 10.220.32.43 to 10.220.32.40 using amqp:
>> org.highwire.activemq.NRPEStatus@4088ead1
>> starting test of 10.220.32.43 to 10.220.32.40 using stomp+nio
>> starting to recieve message: 1461172932817
>> java.io.EOFException: Peer disconnected
>> at
>> org.fusesource.hawtdispatch.transport.AbstractProtocolCodec.read(AbstractProtocolCodec.java:331)
>> at
>> org.fusesource.hawtdispatch.transport.TcpTransport.drainInbound(TcpTransport.java:706)
>> at
>> org.fusesource.hawtdispatch.transport.TcpTransport$6.run(TcpTransport.java:588)
>> at
>> org.fusesource.hawtdispatch.internal.NioDispatchSource$3.run(NioDispatchSource.java:209)
>> at
>> org.fusesource.hawtdispatch.internal.SerialDispatchQueue.run(SerialDispatchQueue.java:100)
>> at
>> org.fusesource.hawtdispatch.internal.pool.SimpleThread.run(SimpleThread.java:77)
>> finished test of 10.220.32.43 to 10.220.32.40 using stomp+nio:
>> org.highwire.activemq.NRPEStatus@264da2a8
>>
>>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message