activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim Bain <tb...@alumni.duke.edu>
Subject Re: Pooled connection factory does not work
Date Thu, 07 Apr 2016 05:16:06 GMT
I have no idea what you're asking.  What are you doing, what are you
expecting to happen in response, and what's actually happening instead?

Tim

On Wed, Apr 6, 2016 at 11:21 AM, Michele <michele.mazzilli@finconsgroup.com>
wrote:

> Hi everyone,
> I work with jboss fuse 6.2.0 based on Apache camel and active mq. I
> configured a pooled connection factory on queue with 10 consumers but only
> one dequeue.
>
> My setup:
> <bean id="jmsConnectionFactory"
>    class="org.apache.activemq.ActiveMQConnectionFactory">
>    <property name="brokerURL" value="tcp://localhost:61616" />
> </bean>
>
> <bean id="pooledConnectionFactory"
>    class="org.apache.activemq.pool.PooledConnectionFactory"
> init-method="start" destroy-method="stop">
>    <property name="maxConnections" value="8" />
>    <property name="connectionFactory" ref="jmsConnectionFactory" />
> </bean>
>
> <bean id="jmsConfig"
>    class="org.apache.camel.component.jms.JmsConfiguration">
>    <property name="connectionFactory" ref="pooledConnectionFactory"/>
>    <property name="concurrentConsumers" value="10"/>
> </bean>
>
> <bean id="activemq"
>     class="org.apache.activemq.camel.component.ActiveMQComponent">
>     <property name="configuration" ref="jmsConfig"/>
> </bean>
>
> And in activemq.xml I set a memory limit to limit number of messages and
> prefetch size with 0 to handle a slow consumer.
>
> Any idea?
>
> Thanks in advance
>
> Best regards
>
> Michele
>
>
>
> --
> View this message in context:
> http://activemq.2283324.n4.nabble.com/Pooled-connection-factory-does-not-work-tp4710421.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message