activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christopher Fogarty <Christopher.Foga...@Versiant.com>
Subject Testing Master Slave on Shared File System
Date Thu, 28 Apr 2016 17:34:17 GMT
I have set up two servers:

Both CENTOS with a shared SAN disk mounted and active on both nodes. 

I have set up ActiveMQ 5.6 

I am able to start each with the following configuration

<persistenceAdapter>
  <kahaDB directory="/sharedFileSystem/sharedBrokerData"/>
</persistenceAdapter>

Each node can and does start, but how can I test, or what do I look for to make sure that
file locking is actually working as described in the http://activemq.apache.org/shared-file-system-master-slave.html
document.  Before putting this into production, I would feel a lot better knowing that only
one of the two nodes is capable of accessing the kahadb.


Chris Fogarty

VP, System Engineering
Versiant Corporation
3700 Arco Corporate Drive
Suite 350
Charlotte, NC 28273
Office: (704) 831-3905 | Mobile: (704) 763-3333

Chris.Fogarty@Versiant.com

-----Original Message-----
From: Christopher Fogarty 
Sent: Wednesday, April 27, 2016 9:02 AM
To: 'users@activemq.apache.org' <users@activemq.apache.org>
Subject: RE: Running ActiveMQ Broker as different username unable to connect via web admin
console

What Platform? Do you have a firewall running

Chris Fogarty

VP, System Engineering
Versiant Corporation
3700 Arco Corporate Drive
Suite 350
Charlotte, NC 28273
Office: (704) 831-3905 | Mobile: (704) 763-3333

Chris.Fogarty@Versiant.com

-----Original Message-----
From: jboss [mailto:jboss@bcidaho.com] 
Sent: Wednesday, April 27, 2016 8:16 AM
To: users@activemq.apache.org
Subject: Re: Running ActiveMQ Broker as different username unable to connect via web admin
console

The web console does not come up at all.   The error that the Chrome gives is
"Connection Refused".  Does not even get to the point of asking for username/password. 

Thanks,




--
View this message in context: http://activemq.2283324.n4.nabble.com/Running-ActiveMQ-Broker-as-different-username-unable-to-connect-via-web-admin-console-tp4711175p4711280.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message