activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Wayne Johnson <w...@yahoo.com.INVALID>
Subject Re: Windows7/ActiveMQ-CPP: getaddrinfo returning “No such host is known” for [::1]
Date Thu, 07 Apr 2016 14:08:42 GMT
Good idea.  Thanks, I'll try that.
 --- 
Wayne Johnson,             | There are two kinds of people: Those 
3943 Penn Ave. N.          | who say to God, "Thy will be done," 
Minneapolis, MN 55412-1908 | and those to whom God says, "All right, 
(612) 522-7003             | then, have it your way." --C.S. Lewis


      From: Timothy Bish <tabish121@gmail.com>
 To: users@activemq.apache.org 
 Sent: Thursday, April 7, 2016 9:04 AM
 Subject: Re: Windows7/ActiveMQ-CPP: getaddrinfo returning “No such host is known” for
[::1]
   
On 04/07/2016 09:53 AM, Wayne Johnson wrote:
> I'm working on modifications to my code to support dual stack environments on Windows
7 et. al. The code uses ActiveMQ-CPP (3.8.4). I've set this up to use a connection to the
broker on URI "tcp://[::1]:61616". I've already found I need to compile APR with APR_HAVE_IPV6.
>
> Now the issue. When APR's call_resolver() method calls getaddrinfo() with the hostname
"[::1]", it returns "No such host is known" (code 11001).
>
> I can ping [::1] without an issue. I've tried uncommenting the ::1 entry in hostnames.
I've added the Internet Protocol Version 6 checkbox on my interfaces.Any ideas what I'm missing?
You might want to ask the APR developers on their mailing list (they are 
not on this list) about the internals, probably won't find many folks 
here who are that knowledgeable on the subject.

-- 
Tim Bish
twitter: @tabish121
blog: http://timbish.blogspot.com/



  
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message