activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michele <michele.mazzi...@finconsgroup.com>
Subject Re: Pooled connection factory does not work
Date Mon, 11 Apr 2016 09:32:32 GMT
Hi,

first of all thanks a lot for your support.

I reset project configuration and it seems work fine as you can see from
screenshot attached  pooled-connection.png
<http://activemq.2283324.n4.nabble.com/file/n4710574/pooled-connection.png> 
.

I used prefetchSize=0 with this activemq.xml configuration  activemq.xml
<http://activemq.2283324.n4.nabble.com/file/n4710574/activemq.xml>  . Other
combinations of prefetchSize (1,2,...10) or memoryLimit on destination cause
Out Of Memory - Heap Space.

But, with this configuration the flow processing is very slowly. I have not
found the right balance between Producer - Consumer in Route.

What is the best practice when you have to process a large number of lines
in file and Slow Consumer passing through ActiveMQ?

My idea is: to give more priority (fastest) to Producer in order to store
all lines of file in Queue and at the same time a Slow Consumers draw from
queue (Throttling: 4msg/1s). Is it a good idea? 
Sorry, but I'm new on this concept.

Thanks a lot again.

Best Regards
Michele





--
View this message in context: http://activemq.2283324.n4.nabble.com/Pooled-connection-factory-does-not-work-tp4710421p4710574.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message