activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lucas Dias <lucas.d...@ceabs.com.br>
Subject Re: Queue hanging with n to n network of brokers
Date Tue, 08 Mar 2016 12:16:00 GMT
Hello,

After many testing, it seems to work fine when reseting the broker. I've
included a reboot step in my recipe to run when a broker comes up or down,
indeed I've seen the network work again.

It looks like the runtime plugin does not fully restores the broker network
when reloading the file.

Answering your question: When looking at the network consumers I see their
number gets increased when there are messages being produced, however
there's no consumption.

The prefetch was just experimental, as you can read at the documentation: 

"If you have very few messages and each message takes a very long time to
process you might want to set the prefetch value to 1 so that a consumer is
given one message at a time."

I was experimenting some values to find any evidence, my hipothesis was the
network connections were holding messages as I've seen too many broker to
broker consumers.

The evidence seems towards the network is still not prepared for dynamic
configurations. 

I will try a few more testing, and eventually come up with more evidences. 

Thank you



--
View this message in context: http://activemq.2283324.n4.nabble.com/Queue-hanging-with-n-to-n-network-of-brokers-tp4707499p4709039.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message