activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim Bain <tb...@alumni.duke.edu>
Subject Re: Help with a Failover testing that shows missing messages
Date Mon, 22 Feb 2016 03:53:33 GMT
Were you missing those messages for all topic consumers, or only for one
but not the other three?

What ack mode does your Camel route use?  What would it do if the broker
was unavailable when it came time to publish to the topic?

Tim
On Feb 21, 2016 7:39 PM, "mtod" <mtod@thetods.net> wrote:

> I setup a fail-over test and ran it over a 12 day term I sent about 100K
> messages to the system. What I found was that messages were getting
> dropped.
>
> •       [2/10/2016 7:23:54 PM] >>>>>>>>>>>>>
Missing Message : 8993
> <<<<<<<<<<<<<<
> •       [2/14/2016 7:00:34 PM] >>>>>>>>>>>>>
Missing Message : 38404
> <<<<<<<<<<<<<<
> •       [2/18/2016 3:05:58 AM] >>>>>>>>>>>>>
Missing Message : 63431
> <<<<<<<<<<<<<<
> •       [2/19/2016 8:08:05 AM] >>>>>>>>>>>>>
Missing Message : 73697
> <<<<<<<<<<<<<<
> •       [2/19/2016 9:11:56 PM] >>>>>>>>>>>>>
Missing Message : 77764
> <<<<<<<<<<<<<<
>
> I really can’t figure out why this would happen any ideas would be greatly
> appreciated.
>
> My Setup:
>
> •       3 Node cluster of ActiveMQ V5.13.0
> •       Running zookeeper V 3.4.7
> •       3 Redhat servers
> •       1 Windows 10 desktop running NMS clients
> •       1 Windows Server running 2008 running NMS clients
>
> Test setup:
>
> •       1 NMS Client publishing an XML messages every 10 seconds
>         o       Connection failover:(tcp://<serverA>:61616,tcp://
> <serverB>:61616,tcp:// <serverC>:61616?initialReconnectDelay=100)
>         o       10000 millisecond delay between messages
> •       Camel route:
>         o       NMS client places the incoming messages into a queue.
>         o       Then Camel routes the message to a Topic
>         o       NMS clients read the messages off the Topic.
> •       4 subscribers reading from a Topic
>         o       Connection failover:(tcp://<serverA>:61616,tcp://
> <serverB>:61616,tcp:// <serverC>:61616?initialReconnectDelay=100)
> •       Failover batch script:
>         o       Reboots a single node every 5 mins.
>
>
>
>
> --
> View this message in context:
> http://activemq.2283324.n4.nabble.com/Help-with-a-Failover-testing-that-shows-missing-messages-tp4707916.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message