activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From THMayr <Thomas.M...@adesso.de>
Subject Integrate ActiveMQ 5.13.1 into WildFly 10.0.0
Date Tue, 23 Feb 2016 07:19:56 GMT
Hi,

I'm trying to integrate ActiveMQ 5.13.1 into WildFly 10.0.0 using the
ActiveMQ reource adapter and a standalone ActiveMQ server. I configured the
reosoure adapter in WildFliy standalone.xml similar as described in the
posting 
https://developer.jboss.org/wiki/HowToUseOutOfProcessActiveMQWithWildFly
<https://developer.jboss.org/wiki/HowToUseOutOfProcessActiveMQWithWildFly> 
. The only difference is that I don't refer to a module but instaead to the
archive:



The resource adaptger is deployed successfully as far as I can see on the
console log of WildFly:



When I deploy the EAR with the message driven bean, I get the folllowing
error message:



I checked, that the MDB class de.adesso.tma.test.ejb.HelloWorldQueueMDB
is in the JAR module of the EAR. The bean is configured as follows:



I don't have any confiruartions in the deployment descriptors ejb-jar.xml or
jboss.xml. I'm not shure about the meaning
of the parameter ?jms.rmIdFromConnectionId=true, which is appended to the
server URL. I also didn't fine any information
how to configure the <admin-objects> correctly (syntax of JNDI and queu
names). I'm also not shure if I should create 
the queues manually in ActiveMQ before I deploy the EAR, or if they are
created with the deoloyment.

Any ideas what is missing?

Thanks Thomas




--
View this message in context: http://activemq.2283324.n4.nabble.com/Integrate-ActiveMQ-5-13-1-into-WildFly-10-0-0-tp4708055.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message