activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From JellyDev01 <tegan.mun...@defence.gov.au>
Subject SecurityException: User name [admin] or password is invalid
Date Thu, 18 Feb 2016 03:31:32 GMT
I am using ActiveMQ v5.11.1 running on a Weblogic RHEL server.
I am able to login to the Web Console and browse all topics and queues using
the admin user and password but I am unable to manually Send a message to
any Topic or Queue. I get the following error (taken from the log):

SecurityException: User name [admin] or password is invalid

I've set it up using standard simpleAuthenticationPlugin in the
conf/activemq.xml file as following:

<simpleAuthenticationPlugin>
<users>
<authenticationUser username="${activemq.username}"
password="{activemq.password}" groups="admins, everyone">
<authenticationUser username="User1" password="1234" groups="User1, admins,
everyone">
</users>
</simpleAuthenticationPlugin>
<authorizationPlugin>
<map>
<authorizationMap>
<authorizationEntries>
<authorizationEntry queue=">" write="admins" read="admins" admin="admins" />
<authorizationEntry topic=">" write="admins" read="admins" admin="admins" />
<authorizationEntry queue="User1." write="User1" read="User1" admin="User1"
/>
</authorizationEntries>
</authorizationMap>
</map>
</authorizationPlugin>

In my credentials.properties file I have:
activemq.username=system
activemq.password=abc123

In this example, User1 is able to remotely read and write to their
respective queue. But as admin from the web console, I am unable to manually
create and Send a message to any queues or topics. The exact error message
taken from the log is:

org.springframework.web.util.NestedServletExceptio: Request processing
failed; nested exception is org.apache.activemq.ConnectionFailedException:
The JMS connection has failed: Force close due to SecutityException on
connect
...........
Caused by: java.lang.SecurityException: User name [admin] or password is
invalid.
...........
WARN ServletHandler - /admin/sendMessage.action
...........
Caused by: java.lang.SecurityException: User name [admin] or password is
invalid.

I have seen a similar post to this but no fixes or remedies. This is causing
a massive issue and I'd really appreciate any fixes :-)
Thank You






--
View this message in context: http://activemq.2283324.n4.nabble.com/SecurityException-User-name-admin-or-password-is-invalid-tp4707715.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message