activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From mhemple <mhem...@gmail.com>
Subject Messages dequeued but not consumed
Date Wed, 10 Feb 2016 02:13:37 GMT
Hi all,

I have a JBoss web application that is currently using embedded HornetQ for
JMS.  We want to switch to an ActiveMQ HA cluster, but I'm running into some
strange issues.  One of my queues (periodicDerivationQueue) is not behaving
as it does with HornetQ.  The AMQ console shows that messages are enqueued
and dequeued, but they are not making it to my consumer.  At first, I
assumed that the messages were dequeuing into the DLQ for some reason, but
that doesn't seem to be the case.  As I understand it, AMQ will not create
the DLQ unless it is necessary.  When I look at the broker there is no DLQ. 
How can I figure out where my messages are going?

I'm also having trouble debugging from the app side of the stack due to
reflection.  I'd like to set a breakpoint on the AMQ side to see whats
happening with my messages, but I'm not sure where to put it.  Any ideas
here?

Could this be a serialization issue?  I've heard that sometimes differences
in serialization between JMS brokers can lead to strange behavior.

I'm really stuck here and any help would be appreciated.  See config info
below.

Wildfly 8.2
AMQ 5.13

ActiveMQ


Standalone.xml (Jboss)







HornetQ


Standalone.xml (Jboss)






--
View this message in context: http://activemq.2283324.n4.nabble.com/Messages-dequeued-but-not-consumed-tp4707380.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message