activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim Bain <tb...@alumni.duke.edu>
Subject Re: Using Broker clusters, javax.management.InstanceAlreadyExistsException:xx
Date Fri, 15 Jan 2016 14:13:27 GMT
Another way you could eliminate this problem (without turning off JMX) is
to change your log4j configuration to set the logging level to ERROR for
org.apache.activemq.network.MBeanBridgeDestination.  You run the risk of
not seeing errors in MBean creation due to other reasons, but in practice
the odds of that are unlikely so there's really not much of a cost, and I
think that's better than disabling JMX entirely.  Just remember to set it
back once you upgrade to a version where the bug is fixed.

Tim

On Wed, Jan 13, 2016 at 9:22 PM, Tim Bain <tbain@alumni.duke.edu> wrote:

> I'd definitely expect that turning off JMX would eliminate the problem,
> since the issue happens when creating the objects JMX uses.  I'm skeptical
> that scheduler support would cause this problem if JMX support is disabled,
> and skeptical that turning it off would eliminate the problem if JMX is
> enabled, so basically I expect that useJmx is the only setting you need to
> change, not both of them.
>
> However, running without JMX support makes it much harder to diagnose
> issues in your broker if you experience them, so I'm not sure I'd choose to
> turn off JMX support rather that just live with a noisy log file; log lines
> that you know aren't a problem are easy to filter our or ignore, and I'd
> rather have JMX available if something starts not working, but it's your
> choice.
>
> Either way, I'd plan to upgrade to 5.14.0 when it's released, at which
> point you should definitely re-enable JMX support.
>
> Tim
>
> On Wed, Jan 13, 2016 at 6:25 PM, softwbc <softwbc@163.com> wrote:
>
>> I try the default configuration for ActiveMQ.
>> Now,I fount that the following two parameters could cause this problem:
>> useJmx="true" schedulerSupport="true"
>> When this configuration is removed,no warn has occurred. So far.
>>
>> but, Previously I tried to change to false.
>>
>> Thanks for your help.
>>
>>
>>
>> --
>> View this message in context:
>> http://activemq.2283324.n4.nabble.com/Using-Broker-clusters-javax-management-InstanceAlreadyExistsException-xx-tp4698127p4705974.html
>> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message