activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim Bain <tb...@alumni.duke.edu>
Subject Re: ActiveMQ KahaDB Directory
Date Fri, 29 Jan 2016 20:58:01 GMT
Yeah, giving the full config may let us spot a problem if there is one.

Also, if you stop the broker and delete the "incorrect" KahaDB directory
and then start the broker again, is the directory recreated immediately
upon startup?
On Jan 29, 2016 7:13 AM, "burner" <bjoernpaulsen1980@googlemail.com> wrote:

> Tim Bain wrote
> > I don't have any guesses about why there would be two KahaDB instances,
> > one
> > by hostname (localhost) and one by the IP address that corresponds to it.
> > I can't imagine that we'd do a DNS lookup to get the IP.  I assume
> there's
> > nowhere in your config where you've used the IP instead of the hostname?
> >
> > When you say "I don't see one Message", are you telling us that you
> expect
> > to see messages (i.e. there are messages on the queue and no consumers
> > connected) but you don't see them on the web page?
>
> Thank you for your replay.
>
> Ok, I can change the Limit, but this don't solve the Problem.
> I can see all Messages, if I am in the Queue List. There are all messages
> everytime, also after I was in the Message List of a Queue and go back. I
> think only for the List of Messages ActiveMQ, or Jetty, take the wrong
> second new KahaDB and in all other cases the right first KahaDB.
>
> I have this 2 Test Routes in there, and yes I see the right count of
> pending
> Messages, dequeued Messages etc. I have a consumer on Test, which
> transfered
> the Messages to Test2. On Test2 is no consumer.
>
> Here my test routes:
> from("timer://foo?fixedRate=true&period=5000").to("activemq:test");
> from("activemq:test").to("activemq:test2");
>
> I put this in my spring config:
> <persistenceAdapter>
>                         <kahaDB directory="activemq-data/localhost/KahaDB"
> journalMaxFileLength="100mb" cleanupInterval="5000"/>
>                 </persistenceAdapter>
>
> But the same Error is Display. With the same values 102400mb (100GB).
>
> I always had a storage limit:
> <systemUsage>
>         <systemUsage>
>                 <memoryUsage>
>                         <memoryUsage percentOfJvmHeap="70" />
>                 </memoryUsage>
>                 <storeUsage>
>                         <storeUsage limit="2 gb"/>
>                 </storeUsage>
>                 <tempUsage>
>                         <tempUsage limit="1 gb"/>
>                 </tempUsage>
>         </systemUsage>
> </systemUsage>
>
> It is helpful, if i send you my full configuration?
>
>
>
>
> --
> View this message in context:
> http://activemq.2283324.n4.nabble.com/ActiveMQ-KahaDB-Directory-tp4706593p4706629.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message