activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim Bain <tb...@alumni.duke.edu>
Subject Re: After failover, earlier messages are lost
Date Fri, 29 Jan 2016 13:33:52 GMT
Only persistent messages are stored in the persistence store;
non-persistent messages will be lost after a restart no matter what
persistence store you choose.  Are you sure your messages are persistent?

If you turn off broker B and repeat your test, what's the behavior?

Tim
On Jan 29, 2016 3:14 AM, "BlueDragon" <shashidhar.b@synchronoss.com> wrote:

> Just wanted to add some info:
> When it works:
> 1. I run a publisher java class [master A and slave B are up]
> 2. Sends messages through master broker A.
> 3. I run consumer java class to receive the messages which works fine.
>
> When it doesn't:
> 1. I run a publisher java class [master A and slave B are up]
> 2. Sends messages through master broker A, once done I stop broker A making
> broker B as the master
> 3. I run the consumer java class which connects to broker B but doesn't
> receive any messages.
>
> Please let me know if I'm missing anything basic here. I really need to
> know
> this to troubleshoot similar setup in our production.
>
> Thanks.
>
>
>
> --
> View this message in context:
> http://activemq.2283324.n4.nabble.com/After-failover-earlier-messages-are-lost-tp4706630p4706634.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message