activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ipolevoy <i...@expresspigeon.com>
Subject ActiveMQ does not send some messages
Date Wed, 27 Jan 2016 23:44:02 GMT
Hi All and thanks for help in advance!

Recently we upgraded from HornetQ to Artemis 1.2 and started to observe
strange behavior. 
Some messages are sitting in largemessages directory and not delivered to
listeners. 
Restarting a Java process forces the broker to clean the directory and
deliver the messages. 

My environment: 
Distributor ID:	Ubuntu
Description:	Ubuntu 14.04.3 LTS
Release:	14.04
Codename:	trusty

java version "1.8.0_66"
Java(TM) SE Runtime Environment (build 1.8.0_66-b17)
Java HotSpot(TM) 64-Bit Server VM (build 25.66-b17, mixed mode)

We are using Artemis as embedded server. It is mostly configured with
defaults, except these values: 

ConnectionFactoryConfiguration cfConfig = new
ConnectionFactoryConfigurationImpl();
cfConfig.setName("cf").setHA(false).setConnectorNames(singletonList("connector")).setBindings("/cf");
cfConfig.setClientFailureCheckPeriod(Long.MAX_VALUE);
cfConfig.setConnectionTTL(-1);
cfConfig.setReconnectAttempts(-1);
cfConfig.setMinLargeMessageSize(250000);

A side question is why it is creating large messages? When I see files in
the largemessages directory, not one file is greater than 150k

Additional info: 
We use JMS to send and consume. We send everything as TextMessage (XML
inside). 

We process about 2 - 4 million messages per day. A few messages (less than
100) may get stuck like this. 

Any help on why some messages are not delivered is much appreciated!

Thanks,   



--
View this message in context: http://activemq.2283324.n4.nabble.com/ActiveMQ-does-not-send-some-messages-tp4706550.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message