activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "yang.yang.zz" <yang.yang...@outlook.com>
Subject Message stuck after failover [5.11.1, 5.13.0]
Date Sun, 10 Jan 2016 09:46:55 GMT
Hi:

I run into an issue that message will get stuck after failover. The
workaround seems to be restarting the consumer broker. Here's my network:

A <--- broker1 ------ duplex network ------- broker*2a* ---> B1

then failover happens, broker2a and B1 are killed (process killed*) and the
backup node broker2b and B2 are up. 

A <--- broker1 ------ duplex network ------- broker*2b* ---> B2

After failover, A can still send message to B2. But all the messages from B2
get stuck on broker2b, until I restart broker 1.

I spent hours and tried everything I could find from the internet including
disabling audit and replayWhenNoConsumers but still not helping.


* it seems when properly shutdown broker2a and B1, this issue doesn't
happen. But what I'm trying to handle is network failure or server power
off. So I have to kill the process.




--
View this message in context: http://activemq.2283324.n4.nabble.com/Message-stuck-after-failover-5-11-1-5-13-0-tp4705730.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message