activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From gbchriste <gary.christe...@gmail.com>
Subject Can't Keep UDP Connection Alive
Date Wed, 30 Dec 2015 15:49:00 GMT
I've been experimenting with ActiveMQ for several weeks using the tcp
transport with no problems.  Now I'm trying to use udp.  No matter how I
configure the udp transport in activemq.xml or the volume of messages sent
over the connection, the connection dies after 30 seconds.  I've seen the
material on inactivity monitor and how to configure it in activemq.xml.  But
a connection using udp doesn't seem to respect those transport options.

I've tried all of the following on the udp transport:

wireFormat.maxInactivityDuration=0
transport.useInactivityMonitor=true
transport.useKeepAlive=true

My understanding is that useInacivityMonitor and useKeepAlive are both true
by default so shouldn't need to be explicitly set.  None the less, setting
these on the udp transport appears to have no effect.

I have a simple publisher and consumer.  The publisher is set up as a simple
Camel project.  The consumer is coded directly against the ActiveMQ library. 
The Consumer is also using synchronous message processing
(consumer.receive())

The publisher sends out a message every second and the consumer is receiving
the messages in a timely manner but the consumer still shuts down after 30
seconds with "Exception in thread "main" javax.jms.JMSException: Channel was
inactive (no connection attempt made) for too (>30000) long"

So I tried adding a timer to the consumer that just sends a heartbeat
message back to the broker every few seconds on the same connection.  The
consumer still dies after 30 seconds.

What am I missing here?



--
View this message in context: http://activemq.2283324.n4.nabble.com/Can-t-Keep-UDP-Connection-Alive-tp4705487.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message