activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim Bain <tb...@alumni.duke.edu>
Subject Re: Persistent messages not moving from embedded broker to remote broker
Date Thu, 15 Oct 2015 12:52:44 GMT
Either Nabble oe the mailing list itself appears to have not acknowledged
either of my two previous replies from 36 hours ago in this thread, since
they're not on the Nabble web page.  That's annoying, especially since I
wasn't given any notification that anything was wrong so I could fix it.

Here's the first one:

OK, so it seems like the standalone -> embedded-consumer connection is
working fine (in that direction, at least), so we want to focus on the
embedded-producer -> standalone path.  While the producer is running, do
you see the producer's embedded broker as a consumer on the advisory topic
for consumers on your topic (ActiveMQ.Advisory.Consumer.TopicTest is the
name I'd expect)?  And do you see the standalone broker as a consumer on
TopicTest in the producer's embedded broker?  You're probably going to want
to use JMX to answer those questions, not the web console.

Tim
On Oct 15, 2015 5:35 AM, "shackman" <f.shackelford@topdesk.com> wrote:

> I was reading "ActiveMQ in Action" and got to the "PEER PROTOCOL" section
> in
> chapter 4. The "EXAMPLE USE OF THE PEER PROTOCOL" on page 93 reads /exactly
> /like the scenario I need to support. So I implemented a PeerGroup version
> of my test.
>
> /I am having the exact same problem! All the connections are there, but no
> messages get passed./
>
> I would think there's something wrong with my producer, but in the previous
> set of test classes, I can demonstrate that when the producer is connected
> directly to a remote stand-alone router (i.e. a running instance of
> activemq
> "out-of-the-box"), the messages get through to the consumer. It's only when
> my producer tries to publish via the embedded broker to another broker that
> messages don't make it out.
>
> There's got to be something simple I must be missing.
>
> Here's my code. The first few classes are there to make it a bit easier to
> write the core classes:
>
> IRunnable
>
> -------------------
>
> -------------------
>
> Utils
>
> -------------------
>
> -------------------
>
> Constants
>
> -------------------
>
> -------------------
>
> SubscribeTopicTest
>
> -------------------
>
> -------------------
>
> PublishTopicTest
>
> -------------------
>
> -------------------
>
> Here's the run log from the Publisher
> -------------------
>
> -------------------
>
> Here's the run log from the Subscriber
> -------------------
>
> -------------------
>
>
>
>
> --
> View this message in context:
> http://activemq.2283324.n4.nabble.com/Persistent-messages-not-moving-from-embedded-broker-to-remote-broker-tp4702884p4702990.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message