activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ekartson <efthimios.kartsona...@inps.co.uk>
Subject org.apache.activemq.transport.InactivityIOException: Channel was inactive for too (>30000) long: tcp://127.0.0.1:61616
Date Mon, 12 Oct 2015 15:45:40 GMT
Hi, I am experiencing the following error (ActiveMQ Artemis broker v1.1.0,
Camel 2.15.2, ActiveMQ client v5.12.0) after only a few minutes of
inactivity:

org.apache.activemq.activemq-osgi - 5.11.1 | Transport
(nio://activemq1:61616) failed, attempting to automatically reconnect
org.apache.activemq.transport.InactivityIOException: Channel was inactive
for too (>30000) long: tcp://127.0.0.1:61616
	at
org.apache.activemq.transport.AbstractInactivityMonitor$4.run(AbstractInactivityMonitor.java:215)[86:org.apache.activemq.activemq-osgi:5.11.1]
	at
java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)[:1.8.0_60]
	at
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)[:1.8.0_60]
	at java.lang.Thread.run(Thread.java:745)[:1.8.0_60]

although the opewire wireFormat.maxInactivityDuration parameter has been set
to 0. 

Thank you in advance for any help.



--
View this message in context: http://activemq.2283324.n4.nabble.com/org-apache-activemq-transport-InactivityIOException-Channel-was-inactive-for-too-30000-long-tcp-127-6-tp4702833.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message