activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From mtod <m...@thetods.net>
Subject Help with Setting up leveldb
Date Wed, 09 Sep 2015 14:10:27 GMT
I'm trying to setup ActiveMQ 5.12.0 using a 3 node leveldb cluster but I keep
getting SASL Warnings.
I can't seem to figure out whats going on.

*ActiveMQ Console:*

WARN | SASL configuration failed: javax.security.auth.login.LoginException:
No JAAS configuration section named 'Client' was found in specified JAAS
configuration file: 'C:\ActiveMQ\apache-activemq-5.12.0
bin\..\conf\login.config'. Will continue connection to Zookeeper server
without SASL authentication, if Zookeeper server allows it.

*Login.config:*

activemq-domain {
    org.apache.activemq.jaas.PropertiesLoginModule required
        org.apache.activemq.jaas.properties.user="users.properties"
        org.apache.activemq.jaas.properties.group="groups.properties";
};

*ActiveMQ.xml :*

		<persistenceAdapter>
			<replicatedLevelDB
				directory="activemq-data"
				replicas="3"
				bind="tcp://0.0.0.0:0"
				securityToken="xxxxxxxx"
				zkAddress="xxxxxxxx.corp.local:2181"
				zkPassword="xxxxxxx"
				zkPath="/activemq/apache-activemq-5.12.0/data"
				hostname="hostxxx.corp.local"
			/>
	   </persistenceAdapter>



Thanks for the help
Mike



--
View this message in context: http://activemq.2283324.n4.nabble.com/Help-with-Setting-up-leveldb-tp4701826.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message