activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christopher Shannon <christopher.l.shan...@gmail.com>
Subject Re: STOMP over secure websocket
Date Thu, 27 Aug 2015 12:01:39 GMT
You should just use wss://myurl:61616 for your URL.  I don't believe you
need the stomp+wss at the end.

On Wed, Aug 26, 2015 at 9:01 PM, ArturoBelano <lauraerinmann@gmail.com>
wrote:

> I configured and restarted activemq according to the documentation to allow
> ssl, wss and stomp+ssl (abbrevated here just to show you what I did there
> are also connections for openwire,etc all on different open ports):
>         <sslContext>
>            all the ssl context info
>         </sslContext>
>
>         <transportConnectors>
>             <transportConnector name="ssl" uri="ssl://localhost:61618"/>
>
>             <transportConnector name="stomp+ssl"
> uri="stomp+ssl://localhost:61615"/>
>
>             <transportConnector name="secure_websocket"
> uri="wss://localhost:61616/>
>         </transportConnectors>
> When I restart activemq the log messages tell me that activemq is listening
> for connections on all of my ports.
> However, everytime I tried to use wss://myurl:61616/stomp+wss I get a
> ailed:
> Error in connection establishment: net::ERR_CONNECTION_REFUSED result.  I'm
> finding it really difficult to debug.  Any suggestions?
>
>
>
> --
> View this message in context:
> http://activemq.2283324.n4.nabble.com/STOMP-over-secure-websocket-tp4701435.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message