activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Clebert <clebert.suco...@gmail.com>
Subject Re: Artemis - Openwire connection fails after 60 seconds
Date Sat, 22 Aug 2015 00:56:05 GMT
I saw this bug right before my  week vacations (along with a performance improvement I made)

I raised a Jira and justin Bertram made a fix. But there is something that still needs a fix
apparently.

I saw this using the chat example under examples/openwire. (I do hope it's the same issue
you are seeing). If you have some time to use that example I would appreciate.  At least I
would know it's the same issue you are seeing.


I am back working on Monday and I will work on it. 


Thanks. 

-- Clebert Suconic typing on the iPhone. 

> On Aug 21, 2015, at 14:10, slew77 <stephen.lewis77@yahoo.co.uk> wrote:
> 
> If you could, that would be absolutely fantastic!!
> 
> Many thanks,
> Steve.
> 
> 
> Clebert Suconic wrote
>> I will fix this on Monday. Ok?
>> 
>> -- Clebert Suconic typing on the iPhone. 
>> 
>>> On Aug 21, 2015, at 12:45, slew77 &lt;
> 
>> stephen.lewis77@.co
> 
>> &gt; wrote:
>>> 
>>> Hi Clebert,
>>> 
>>> Unfortunately I get similar results with the master branch:
>>> 
>>> 17:20:02,800 WARN  [org.apache.activemq.artemis.core.server] AMQ222067:
>>> Connection failure has been detected: AMQ119014: Did not receive data
>>> from
>>> /127.0.0.1:55098. It is likely the client has exited or crashed without
>>> closing its connection, or the network between the server and client has
>>> failed. You also might have configured connection-ttl and
>>> client-failure-check-period incorrectly. Please check user manual for
>>> more
>>> information. The connection will now be closed.
>>> [code=CONNECTION_TIMEDOUT]
>>> 17:20:02,800 WARN  [org.apache.activemq.artemis.core.server] AMQ222061:
>>> Client connection failed, clearing up resources for session
>>> ID:Laptop95-57804-1440153508257-1505:1:-1
>>> 17:20:02,801 WARN  [org.apache.activemq.artemis.core.server] AMQ222107:
>>> Cleared up resources for session
>>> ID:Laptop95-57804-1440153508257-1505:1:-1
>>> 17:20:02,804 WARN  [org.apache.activemq.artemis.core.server] AMQ222061:
>>> Client connection failed, clearing up resources for session
>>> ID:Laptop95-57804-1440153508257-1505:1:1
>>> 17:20:02,805 WARN  [org.apache.activemq.artemis.core.server] AMQ222107:
>>> Cleared up resources for session ID:Laptop95-57804-1440153508257-1505:1:1
>>> 17:20:02,806 INFO  [org.apache.activemq.artemis.core.server] AMQ221021:
>>> failed to remove connection
>>> 
>>> The Jmeter tests runs for 60 seconds, sending/receiving messages to/from
>>> the
>>> broker. At 60 seconds the logs above appear and the client loses its
>>> connection.
>>> 
>>> The broker is just setup using "artemis create instance", with all the
>>> default values.
>>> 
>>> Would love to get it working!
>>> 
>>> Thanks,
>>> Steve.
>>> 
>>> 
>>> Clebert Suconic wrote
>>>> We have fixed this on master.  
>>>> 
>>>> 1.0.0 was the first release won openwire.  We are doing a lot of work on
>>>> open wire for next ones. 
>>>> 
>>>> 
>>>> Perhaps you could build master and try it out before we release ?
>>>> 
>>>> -- Clebert Suconic typing on the iPhone. 
>>>> 
>>>>> On Aug 21, 2015, at 06:37, slew77 &lt;
>>> 
>>>> stephen.lewis77@.co
>>> 
>>>> &gt; wrote:
>>>>> 
>>>>> Hi,
>>>>> 
>>>>> I have setup a client (Jmeter) using an Openwire connection to an
>>>>> Artemis
>>>>> broker.
>>>>> 
>>>>> With one thread continually publishing and consuming messages,
>>>>> everything
>>>>> is
>>>>> fine for 60 seconds, then the broker issues the messages:
>>>>> 
>>>>> 11:31:42,665 WARN  [org.apache.activemq.artemis.core.server] AMQ222061:
>>>>> Client connection failed, clearing up resources for session
>>>>> ID:Laptop95-35846-1440152943137-3:2:-1
>>>>> 11:31:42,666 WARN  [org.apache.activemq.artemis.core.server] AMQ222107:
>>>>> Cleared up resources for session ID:Laptop95-35846-1440152943137-3:2:-1
>>>>> 11:31:42,684 WARN  [org.apache.activemq.artemis.core.server] AMQ222061:
>>>>> Client connection failed, clearing up resources for session
>>>>> ID:Laptop95-35846-1440152943137-3:2:1
>>>>> 11:31:42,686 WARN  [org.apache.activemq.artemis.core.server] AMQ222107:
>>>>> Cleared up resources for session ID:Laptop95-35846-1440152943137-3:2:1
>>>>> 11:31:42,687 INFO  [org.apache.activemq.artemis.core.server] AMQ221021:
>>>>> failed to remove connection
>>>>> 
>>>>> And then the client can no longer send anything until it is restarted.
>>>>> 
>>>>> Because it is consuming what it sends, the queue is not blocking due
to
>>>>> being full.
>>>>> 
>>>>> Two main questions are:
>>>>> 1. Should I be configuring the broker specially for openwire clients
>>>>> 2. Is it too early to use Artemis for production? I really like the HA
>>>>> and
>>>>> scaling features, but maybe it's still too soon?
>>>>> 
>>>>> Thanks for any help,
>>>>> Steve.
>>>>> 
>>>>> 
>>>>> 
>>>>> 
>>>>> 
>>>>> 
>>>>> --
>>>>> View this message in context:
>>>>> http://activemq.2283324.n4.nabble.com/Artemis-Openwire-connection-fails-after-60-seconds-tp4701266.html
>>>>> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>>> 
>>> 
>>> 
>>> 
>>> 
>>> --
>>> View this message in context:
>>> http://activemq.2283324.n4.nabble.com/Artemis-Openwire-connection-fails-after-60-seconds-tp4701266p4701288.html
>>> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
> 
> 
> 
> 
> 
> --
> View this message in context: http://activemq.2283324.n4.nabble.com/Artemis-Openwire-connection-fails-after-60-seconds-tp4701266p4701290.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message