activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From slew77 <stephen.lewi...@yahoo.co.uk>
Subject Artemis - Openwire connection fails after 60 seconds
Date Fri, 21 Aug 2015 10:37:07 GMT
Hi,

I have setup a client (Jmeter) using an Openwire connection to an Artemis
broker.

With one thread continually publishing and consuming messages, everything is
fine for 60 seconds, then the broker issues the messages:

11:31:42,665 WARN  [org.apache.activemq.artemis.core.server] AMQ222061:
Client connection failed, clearing up resources for session
ID:Laptop95-35846-1440152943137-3:2:-1
11:31:42,666 WARN  [org.apache.activemq.artemis.core.server] AMQ222107:
Cleared up resources for session ID:Laptop95-35846-1440152943137-3:2:-1
11:31:42,684 WARN  [org.apache.activemq.artemis.core.server] AMQ222061:
Client connection failed, clearing up resources for session
ID:Laptop95-35846-1440152943137-3:2:1
11:31:42,686 WARN  [org.apache.activemq.artemis.core.server] AMQ222107:
Cleared up resources for session ID:Laptop95-35846-1440152943137-3:2:1
11:31:42,687 INFO  [org.apache.activemq.artemis.core.server] AMQ221021:
failed to remove connection

And then the client can no longer send anything until it is restarted.

Because it is consuming what it sends, the queue is not blocking due to
being full.

Two main questions are:
1. Should I be configuring the broker specially for openwire clients
2. Is it too early to use Artemis for production? I really like the HA and
scaling features, but maybe it's still too soon?

Thanks for any help,
Steve.






--
View this message in context: http://activemq.2283324.n4.nabble.com/Artemis-Openwire-connection-fails-after-60-seconds-tp4701266.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message