activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vavricka <vavricka.to...@gmail.com>
Subject Re: Artemis: Cannot send or receive to queue
Date Fri, 07 Aug 2015 12:32:40 GMT
I am using:

qpid-jms-client -
http://mvnrepository.com/artifact/org.apache.qpid/qpid-jms-client/0.3.0
qpid-amqp-1-0-client -
http://mvnrepository.com/artifact/org.apache.qpid/qpid-amqp-1-0-client-jms/0.32

But I finally found my mistake.

When I checked queue by jolokia I found that there is defined some filter.
And if I checked other queues (queues where sending/receiving works fine) I
found that there is filter=null.

It probably happened when I tried to create first core queue. I simply
copied an example from documentation (where is defined filter and that queue
is durable) and started server.
After that I removed filter and durable parameters and I thought that queue
will change accordingly.

That was obviously bad guess.

Hope this can help others in same situation.

Thanks a lot for your help.
Vavricka


andytaylor wrote
> What client are you using to subscribe?
> 
> If you provide some instructions as to how to reproduce i will take a
> look?
> 
> btw, you can view the queues and it sstate (inclusing message count) via 
> jconsole or JMX





--
View this message in context: http://activemq.2283324.n4.nabble.com/Artemis-Cannot-send-or-receive-to-queue-tp4700484p4700550.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message