activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vavricka <vavricka.to...@gmail.com>
Subject Artemis: Cannot send or receive to queue
Date Thu, 06 Aug 2015 10:29:06 GMT
Hi, 

I set up artemis broker by readme file. I successfully managed to get
artemis broker working.

When I want to test against JMS clients
(http://mvnrepository.com/artifact/org.apache.qpid/qpid-jms-client/0.3.0 and
http://mvnrepository.com/artifact/org.apache.qpid/qpid-amqp-1-0-client-jms/0.32)
I was able to send and receive messages by using JMS queues, specified in
broker.xml like below:

<jms xmlns="urn:activemq:jms">
    <queue name="DLQ"/>
    <queue name="ExpiryQueue"/>
</jms>

But these queues are named jms.queue.DLQ and jms.queue.ExpiryQueue,
"jms.queue" prefix is not usable for me.

So I tried to create core queue by:

<core xmlns="urn:activemq:core">
    <queues>
        <queue name="test.queue">
            <address>test.queue</address>
        </queue>
    </queues>
...
</core>

Queue was successfully created and I start testing JMS clients.

JMS clients worked fine with JMS queues (queue name was with "jms.queue"
prefix), but when I try to send message to core queue (test.queue) nothing
happened. I tried also send message by qpid-send (which supports AMQP 1.0
protocol) with same results.

I also tried routing by setting "address-setting" and "diverts", but all is
working only with JMS queues.

When I was playing with clients I found that queues created by client (in my
case embeddedExample from core) by:

         ClientSession coreSession = sf.createSession(false, false, false);
         final String queueName = "test.queue2";
         coreSession.createQueue(queueName, queueName, true);
         coreSession.close();

works fine with JMS clients.

When queue is created by client and not by server configuration I was able
to send and receive messages by JMS clients (both) and qpid-send and
qpid-receive as well.

Am I doing something wrong with artemis broker configuration?

Thanks



--
View this message in context: http://activemq.2283324.n4.nabble.com/Artemis-Cannot-send-or-receive-to-queue-tp4700484.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message